icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.czmgbb.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

5050彩票 www.575504.com-福利彩票招聘| www.837788.com-网上福彩投注合法吗| www.gm33.cc-致富彩票平台| www.38.cc-七星彩结局明月珰| www.020164.com-中彩网大乐透推荐| www.228111.cc-江苏快三有人控制吗| www.900062.cc-657彩票网官网| www.980039.com-彩票店如何装修| www.al55.com-福彩了d图迷总汇| www.tb53.com-快三和值对照表| www.66ei.com-爱尚彩平台怎么样| 500彩票网www.960737.com| www.190253.com-安徽快三质合走势图| www.302488.com-乐彩论坛福彩首页| www.398111.cc-福彩网手机客户端| www.563368.com-今日大乐透彩民乐图| www.64wv.com-一分彩计划网| www.721308.com-彩宝网首页新版| www.202836.com-北京快三数字走势图| 大赢家彩票平台www.218565.com| www.684199.com-下载彩八app| www.956.tv-七星彩如何才算中奖| www.611223.com-彩票贷款案例流程| www.229060.com-大发分分彩计划在线| www.893396.cc-爱彩乐开奖走势图| www.974745.com-中国福建省体彩官网| www.pt05.com-北京六分快三查询| www.975847.com-河南彩礼文件| www.f34.net-国乐彩官网登录| www.633441.com-买彩票有什么窍门| www.570359.com-七彩神仙鱼怎么养| www.e11.space-彩民网站-| www.444054.com-富贵彩票内部透码| www.610048.com-那些快三彩票合法| www.11800.com-泰国彩票玩法| www.678240.com-彩票技术论坛| www.970766.com-买彩票能中大奖吗| www.0232.pw-中国福利彩票案| www.65pz.com-卖体育彩票怎么提成| www.459679.com-七星彩中奖号码预则| www.811272.com-山西福彩3d走势图| www.619.tv-彩时时彩预测家安卓| www.718282.com-体育彩票直播开奖| www.273028.com-体育彩票宗旨| www.556660.com-黑彩怎么做庄| www.825113.com-买彩票上瘾了怎么戒| www.983865.com-808彩彩票网站| www.qf22.com-彩77ios-| www.74nx.com-惠盈彩票-| www.187616.com-时时彩开彩结果| www.632666.com-云南七彩捞腌菜| www.56ff.com-竟彩胜平负投注| www.3566.vip-网络上哪里能玩快三| www.j24.me-i8彩票线路检测| www.90yp.com-22彩票违法么| www.cb43.com-81彩票下载-| www.yf55.com-下载派彩每日推荐| www.523352.com-福龙彩票平台| www.225749.com-福彩双色球作弊视频| www.63115.com-河南洛阳彩礼多少钱| 大赢家彩票平台www.186793.com| www.14sq.com-qq时时彩计划| www.7180.vip-博彩公司怎么赚钱| www.838174.com-七星彩奖号-| www.956028.com-彩票可以破解吗| 500彩票网www.607995.com| www.355396.com-彩乃奈奈楼梯照片| www.549290.com-刷彩网是真的吗| www.2008.org-微站宝彩票-| www.2066.cm-易彩国际是个什么| www.576264.com-旺彩是骗人-| www.043669.com-七是彩论坛特区| www.040090.com-万豪彩票苹果版| www.109506.com-手机彩票挂机| www.101407.com-198华阳彩票官网| www.188824.com-快乐彩开奖号码走势| www.276533.com-快三反倍投教学| www.889090.com-香港彩神网论坛| www.389708.com-体彩开奖结果体| www.565609.com-深圳体彩店怎么申请| www.764553.com-玩彩六点半-| www.955526.com-01vip彩票官网| www.49kt.com-彩73领导者-| www.94766.com-福彩3d结果查询| www.181729.com-彩票送彩金38元| www.302052.com-全民中彩app贴吧| www.326576.com-乐彩论坛排列三| www.343318.com-立日彩票-| www.9701.org-体育彩票出什么奖| www.137326.com-旺彩开奖结果下载版| www.222071.com-北京体育彩票网点| www.623.cm-中国彩票双色球| www.9710.org-类似彩宝彩票的软件| www.59800.cc-必发彩票手机导航| www.014272.com-彩票平台系统出租| www.044199.com-彩叶桂致富故事| www.112361.com-福彩3d推荐号今天| www.171695.com-江西多乐彩今日开奖| www.ay56.com-彩票开奖查询彩票l| www.wj24.com-57彩票-| www.30ns.com-福彩3d和值13| www.694281.com-中体彩唯一官网| www.728276.com-海南彩票软件| www.804032.com-福彩字谜图谜总会| www.873902.com-贵州快三玩法和开奖| www.947417.com-彩吧第三版图库| www.993656.com-足彩第19044期| www.bn00.com-探探全是彩票托| www.52812.cc-好彩投吧-| www.89883.com-网易模拟彩票| www.751489.com-田伟足彩解盘分析| www.883261.com-快彩合法吗-| www.15iy.com-腾讯分分彩后三跨度| www.349585.com-老彩票平台代理| www.827058.com-南方彩票安装| www.825971.com-uu彩票直播-| www.4868.org-趣彩彩票正规吗| www.751666.cc-中彩彩票飞艇软件| www.09903.com-齐鲁风采是什么彩票| www.91766.com-今天好彩一-| www.079308.com-大玩家彩票提不了款| www.166577.com-快三彩票在线投注| www.307628.com-福建福彩官网首页| www.123698.com-排列三乐彩网首页| www.127964.com-羽泉彩虹原版| www.204385.com-人人彩票网注册| www.305766.com-易彩是真的吗| www.329.me-彩票银海图-| www.821126.com-吉林快三软件自动| www.6241.vip-青哇彩8时万| www.43218.com-i福彩3d开号| www.516167.com-一分钱起投的彩票| www.197994.com-长春体彩快3走势图| www.51159.com-重庆时时彩无法提现| www.485900.com-飞彩网app下载| www.393975.com-3位数的彩票是什么| www.191275.com-分分快三在线计划| www.334822.com-上海彩选4开奖结果| www.327679.com-广东天彩快三| www.708135.com-竞彩足球怎样分析| www.780771.com-88官方网彩票| www.845926.com-网上代玩彩票兼职| www.901167.com-皇都彩票是骗人的| www.971769.com-下载8号彩-| 500彩票www.66653k.com| www.878608.com-江西福彩玩法介绍| www.388794.com-福彩3d天牛彩报| www.557792.com-北京快三下载软件| www.657036.com-彩贝游戏兑换码获取| www.380807.com-鲁豫采访彩票大奖者| www.768852.com-好彩网可靠吗| www.920975.com-中国福彩网上购买| www.966707.com-宝马彩票安卓下载| 奔驰彩票www.29178h.com| www.s38.org-广西彩票官网下载| www.80jp.com-中彩票需要交多少税| www.130835.com-安然七星彩-| www.209758.com-黑彩代理怎么挣钱| www.299750.com-内蒙快三28期结果| www.98ec.com-江苏体彩七位数历史| www.10ti.com-租彩票平台多少钱| www.169880.com-甘肃快3彩经| www.971207.com-体育彩票怎么中奖| www.663992.com-今天打什么码七星彩|